Planet eStream Support

Plugins

Please see below for the range of VLE plugins currently available for Planet eStream

Moodle Assignment Submission Plugin
Use Planet eStream content as a submission for Moodle assignment. This plugin must also be installed for use of the text editor plugins below.
Download

Moodle iFrame
This plugin must be installed for use of the TinyMCE / ATTO text editor plugins below.
Download

Moodle TinyMCE Plugin
Embed content from Planet eStream into your Moodle environment using the TinyMCE text editor, or upload videos directly to both platforms.
Download

Moodle ATTO Plugin
Embed content from Planet eStream into your Moodle environment using the ATTO text editor, or upload videos directly to both platforms.
Download

Moodle Authentication Plugin
Authenticate users with matching Moodle and Planet eStream usernames, allowing automatic login for embedded quizzes.
Download

Canvas Plugin
Embed content from Planet eStream into your Canvas courses, or upload videos directly to both platforms.
Download

Firefly Plugin
Embed content from Planet eStream into your Firefly front page, or upload videos directly to both platforms.
Download

D2L Brightspace Plugin Installation Guide
Embed content from Planet eStream into your D2L Brightspace platform.
View Guide

SharePoint Plugin
Embed content from Planet eStream into your Sharepoint pages, or upload videos directly to both platforms.
Download

Note:We are currently considering development of a Wordpress 5 Gutenberg plugin. However, we believe that the Guternberg editor will likely become optional this year due to negative user feedback. In the meantime, you may install the official Wordpress "classic editor" plugin which will reinstate the TinyMCE editor, and with it, the Planet eStream plugin.

WordPress Plugin
Note: Supports Wordpress versions up to 4.9.9. Embed content from Planet eStream into your Wordpress blog, or upload videos directly to both platforms.
Download

WordPress Plugin (Old)
This version of the plugin is no longer supported/recommended, but you are free to use it in place of the newer TinyMCE version.
Download

Blackboard Plugin
Note: The Blackboard plugin has been tested and updated to conform to Blackboard's JDK11 update, while still working on JDK8 versions of Blackboard. However, if you are using a Blackboard version from before Q2 2016, or an eStream version that is 6.40.06.07 or below, please contact eStream Support.
Download